2021/06/07
Cisco921JとMeraki Goを組合せてホームネットワークを構築しました
概要
小規模オフィスのネットワーク構築を以下の2つの製品を使って行いました。
またプロバイダーは以下のような状況でした。
- 弊社オフィスにはマンションタイプの光回線が引いてあり、自室のLANケーブルをつなぐだけで基本的には通信が可能になるタイプです。(PPPoEなどは不要)
- 固定グローバルIPサービスに加入しており、固定のIPアドレス・サブネットマスク・デフォルトゲートウェイなどは払い出されていました
設定したネットワークは以下の図のような感じになります。
921Jの設定
921Jへの接続
ルーター「Cisco 921J」への接続ですが、手持ちのMac(mini)からの接続にコンソールケーブルが必要でした。
以下のケーブルを購入しました。
こちらのケーブルはコンソールポートからUSBに直接繋げるため便利でした。さらに、ドライバーインストール不要ですぐに使うことができました。(Max OS 11.Xの場合、特段ドライバーをインストール不要とのことでした。)
Please be advised Mac OS BIg Sur 11.X is natively supported and does not require a driver install.
Thank you.
Macからの接続
% ls -l /dev/tty.*
crw-rw-rw- 1 root wheel 9, 4 5 31 17:02 /dev/tty.usbserial-1430
% screen /dev/tty.usbserial-1430
# その後、ルーターの電源をONにすると、ワラワラ出力されてきます。
# 途中で以下聞かれるので、noを選択します。
Would you like to enter the initial configuration dialog? [yes/no]: no
初期設定の確認
# 特権EXECモードになる
Router>enable
# 現状の設定を確認する
Router#show running-config
Building configuration...
Current configuration : 1031 bytes
!
! Last configuration change at 08:12:34 UTC Mon May 31 2021
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
license udi pid C921J-4P sn FGL2518L3KB
!
redundancy
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
control-plane
!
line con 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
host名の変更
Router#configure terminal
Router(config)#hostname kumanote01
kumanote01(config)#
パスワードの変更+α
kumanote01(config)#enable secret YOUR-OWN-PASSWORD
kumanote01(config)#no ip domain-lookup
kumanote01(config)#no ip http server
kumanote01(config)#no ip http secure-server
kumanote01(config)#end
WAN側のインターフェース設定
固定ipサービスで指定されたipアドレス(とサブネットマスク)を設定します。
kumanote01#configure terminal
kumanote01(config)#interface GigabitEthernet 4
kumanote01(config-if)#ip address XXX.XXX.XXX.XXX YYY.YYY.YYY.YYY
kumanote01(config-if)#no shutdown
kumanote01(config-if)#exit
Default Routeの設定
固定ipサービスで指定されたデフォルトゲートウェイを設定します。
kumanote01(config)#ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX
DNSサーバーの指定
kumanote01(config)#ip name-server 8.8.8.8 8.8.4.4
VLANの設定
vlan 10
を192.168.10.0/24
で作成し、インターフェースには192.168.10.254/24
を設定しました。- 直接PC接続するので、
access
モードで設定しました。
kumanote01#show vlan-switch
kumanote01#configure terminal
kumanote01(config)#vlan 10
kumanote01(config-vlan)#name Home
kumanote01(config-vlan)#exit
kumanote01(config)#interface range GigabigEthernet 0 - 2
kumanote01(config-if-range)#switchport mode access
kumanote01(config-if-range)#switchport access vlan 10
kumanote01(config-if-range)#end
kumanote01#show vlan-switch
kumanote01#configure terminal
kumanote01(config)#interface vlan 10
kumanote01(config-if)#ip address 192.168.10.254 255.255.255.0
kumanote01(config-if)#ip nat inside
kumanote01(config-if)#no shutdown
kumanote01(config-if)#exit
DHCPの設定
192.168.10.201
~192.168.10.254
は割り当てられないようにしました。- リース期間に1日を設定しました。
kumanote01#configure terminal
kumanote01(config)#service dhcp
kumanote01(config)#ip dhcp excluded-address 192.168.10.201 192.168.10.254
kumanote01(config)#ip dhcp pool dhcp-vlan10
kumanote01(dhcp-config)#network 192.168.10.0 255.255.255.0
kumanote01(dhcp-config)#default-router 192.168.10.254
kumanote01(dhcp-config)#dns-server 8.8.8.8 8.8.4.4
kumanote01(dhcp-config)#lease 1
kumanote01(dhcp-config)#end
kumanote01#show ip dhcp pool dhcp-vlan10
PATの設定
vlan 10
の内部ローカルアドレスからの通信を固定ipサービスで指定されたipアドレスに変換できるようにします。(vlan10には複数の機器が繋がっているため、overload
の指定をしました。)
kumanote01#configure terminal
kumanote01(config)#ip access-list extended pat-list
kumanote01(config-ext-nacl)#permit ip 192.168.10.0 0.0.0.255 any
kumanote01(config-ext-nacl)#exit
kumanote01(config)#interface GigabitEthernet 4
kumanote01(config-if)#ip nat outside
kumanote01(config-if)#exit
kumanote01(config)#ip nat inside source list pat-list interface GigabitEthernet4 overload
kumanote01(config)#exit
NTP設定
kumanote01#show clock
kumanote01#configure terminal
kumanote01(config)#clock timezone JST 9
kumanote01(config)#ntp server asia.pool.ntp.org
kumanote01(config)#exit
kumanote01#show clock
設定の保存
kumanote01#copy running-config startup-config
Meraki Goの設定
無線アクセスポイントであるMeraki Goの設定を行いました。
- セットアップガイドに基づいて設定
- ここらへんの記事をみつつ、ブリッジモードに変更
- 設定を変更後、電源をON→OFF→ONにして再起動して接続し直しました。(数分程度待つと接続が確認できるようにりました。)
その他
VLANの削除
設定したVLANはルータ本体を工場出荷状態に戻しても消えないので、flash内のvlan.datを削除する必要があります。
kumanote01#dir
kumanote01#delete flash:vlan.dat
Delete filename [vlan.dat]? [Enter]
Delete flash:vlan.dat? [confirm] [Enter]
kumanote01#reload
参考
関連する記事
Cisco921JにPPPOEを使ってインターネット回線を利用できるようにしました
オフィス移転に伴い、WANの構成をPPPOEを使うように修正しました
Ciscoのルーター(921J)にSSHでコンソールに接続できるように設定する
Ciscoルーター(921J)にSSHで接続して設定ができるようにしました。
Cisco SG110Dがホームネットワークの仲間入りしました
ポートが足りなくなったので、cisco製の小規模オフィス用アンマネージドスイッチを購入してホームネットワークに追加しました。
Cisco921JとMeraki Goを組合せてホームネットワークを構築しました
kumanoteの小規模オフィス用のネットワークをcisco機器を使って構築しました